0

I cannot enable product reviews on a Magento 1.9.1.1 installation.

The module output is enabled in

System > Configuration > Advanced > Advanced > Disable Modules Output

However no trace of Product reviews in

System > Configuration > Catalog

or

Catalog

The website previously had installed Yotpo reviews but the module has been uninstalled.

I also verified the theme xml configuration files and there is no reviews module suppresion.

Any hints on troubleshooting?

1

Try this workaround:

Check if the module is enabled in: etc/modules/Mage_All.xml <Mage_Review>

Then check frontend

Switch to Default or RWD theme

Now you should be able to see the reviews block, now compare the contents of these files with your theme ones:

  • app/design/frontend/base/default/layout/catalog.xml
  • app/design/frontend/base/default/layout/review.xml

vs

  • app/design/frontend/{pkg}/{theme}/layout/catalog.xml
  • app/design/frontend/{pkg}/{theme}/layout/review.xml

and

  • app/design/frontend/{pkg}/{theme}/layout/local.xml

If you don't find any difference and/or the Reviews block is present there so the problem is in the phtml.

Check app/design/frontend/{pkg}/{theme}/catalog/product/view.phtml

you must find something like that:

<?php echo $this->getReviewsSummaryHtml($_product, false, true)?>
  • the etc/modules/Mage_All.xml did the job! – Mike Feb 10 '16 at 9:03
  • Cool, the short path! – MauroNigrele Feb 10 '16 at 9:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.