Yes I know another Cron problem with version 1.9, but I honestly have looked through so many posts here and on Mage Forums and I have gotten nowhere.

So I have gone into my Cpanel (Magento and have tried several different cron job calls. like

  • /usr/bin/php -f /home/exmaple/public_html/cron.php

    php -f /home/example/public_html/cron.php

    /bin/sh /home/example/public_html/cron.sh

I also have the AOE plugin installed. I have generated a schedule in the plugin and also went in my phpmyadmin and the cron table has a list of jobs that are "pending". It one of the SE posts it mentioned adding "$isShellDisabled = true;" to the cron.php file. I also tried that.

For the longest time it said no heart beat until I disables the htaccess file in the root directory where my magento store is installed. From there I can type in the url/cron.php and it will show a blank page and I begin to receive emails and when i refresh AOE it shows the cron jobs processed. The cron.php and sh files are set to 644. If I disable htaccess and manually access the php file...it works and that is as close as I have gotten to getting the system to function. When I bring back the htaccess file i get the 404 default magento screen and nothing gets processed. I'm not sure how to fix this?

2 Answers 2


A .htaccess file will only affect through the web browser. Please type sudo crontab-e in terminal and show us your crontab configuration.

Please also type chmod +x cron.sh in the directory of where the cron sh file is located


you could only deactivate the rule for the cron.php in the .htaccess file (just search for cron). Since one of the last Security Patches (I think 6788?) you cannot access it anymore over the webserver due to that .htaccess line

Next better way would be to extend the rule so the cron.php is only reachable from the ip of your service that calls it regulary.

The best way would surely be to call cron.sh (or the aoe schedulers scheduler_cron.sh), but I'm not sure why this is not working on your system

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.