0

I am getting these error messages when attempting to install Magento using the auto install (installatron) with cPanel.

I've setup EasyApache 3 to already upgrade my PHP and MySQL versions but these two messages are still prohibiting me to proceed with the install. Any help would be greatly appropriated in finishing the setup of my Godaddy WHM

php-pdo-mysql-version-minimum v1 (detected: OFF)
php-intl-version-minimum v1 (detected: OFF)
  • You could check the intl option beneath the PDO options, than php 5.6 is also good. – Alain Stout Jul 13 '16 at 18:27
0

I've managed to resolve the "php-pdo-mysql-version-minimum v1 (detected: OFF)" by doing the following in WHM:

  • Goto WHM »Software »EasyApache 3 (Apache Update)
  • Select "Previously
  • Saved Config (** DEFAULT **)" and click "Start customizing based on profile"
  • On the "Apache Version 3" page click "Next"
  • On the "PHP 5.6 Version" page click "Next"
  • On the "Short Options List" page
  • click"Exhaustive Options List" On the "Exhaustive Options List" ensure that PDO, PDO sqlite and PDO MySQL are selected.
  • Then Click Build on the bottom of the page.

However, I am still attempting to resolve the "php-intl-version-minimum v1 (detected: OFF)"

-1

Found the answer. So what the main issue here is that Magento 2.0+ requires PHP 7 and the WHM portal provided PHP 5.6 as the most recent version. If anyone runs into this issue, know that you'll need to either install PHP 7 or downgrade to Magento 1.9...

  • That's not true. The minimum requirement for Magento 2.0 is PHP 5.5 and I can confirm that it works. Your PHP installation lacked the php5-intl extension. – Fabian Schmengler Feb 10 '16 at 11:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.