0

So a customer complained that she would not buy anything without secure check out. Googled SSL and Magento. Found an article on how to turn the ssl on (https://www.siteground.com/tutorials/magento/magento_ssl.htm).

Followed instructions, not realizing my SSL certificate was expired. When I hit save I was kicked out of the admin and cannot log back in.

Followed fix instructions here: https://wiki.magento.com/pages/viewpage.action?pageId=10223941

Did not work. I'm wondering what my next steps to fix it are. I have no ssl experience and today was the first time I've ever even seen the core_config_data table. I inherited this site about 1.5 years ago.

Thanks for any help!!

4
  • post your core_config_data table snapsot Feb 8, 2016 at 19:52
  • I'm not sure how to post photos but it looks like:
    – IanTea
    Feb 8, 2016 at 20:15
  • 1 default 0 general/region/display_all 1 2 default 0 general/region/state_required AT... 3 default 0 catalog/category/root_id 2 4 default 0 admin/dashboard/enable_charts 1 5 default 0 web/unsecure/base_url shop.memteaimports.com 6 default 0 web/secure/base_url shop.memteaimports.com 7 default 0 general/locale/code en_US 8 default 0 general/locale/timezone America/Los_Angeles 9 default 0 currency/options/base USD 10 default 0 currency/options/default USD 11 default 0 currency/options/allow USD 12 default 0 web/secure/use_in_adminhtml 0 13 default 0 web/secure/use_in_admin 0
    – IanTea
    Feb 8, 2016 at 20:19
  • 2
    Possible duplicate of How to disable secure url for admin
    – MagenX
    Feb 9, 2016 at 8:42

1 Answer 1

0

It's not exactly a Magento answer, but... Your SSL certificate being expired shouldn't prevent you logging in to the site, it's just going to make your browser show warnings. In chrome, there's a link at the bottom right advanced, if you click this you should then have an option to Proceed to yoursite.com (unsafe). Once you've selected this you should be able to login and change the setting.

5
  • No link sadly just this: Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator at [email protected] to inform them of the time this error occurred, and the actions you performed just before this error. More information about this error may be available in the server error log. Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
    – IanTea
    Feb 8, 2016 at 20:19
  • Apache/2.4.10 (Unix) OpenSSL/1.0.1e-fips mod_bwlimited/1.4 Server at memteaimports.com Port 443
    – IanTea
    Feb 8, 2016 at 20:19
  • This error should not occur just because of an expired SSL. PHP is crashing, you'll have to check your error log to diagnose. Feb 8, 2016 at 20:22
  • Error log is saying: [Mon Feb 08 11:55:23.236031 2016] [access_compat:error] [pid 1687:tid 140477812504320] [client 67.227.190.235:48446] AH01797: client denied by server configuration: /home/memteaim/public_html/app/etc/local.xml
    – IanTea
    Feb 8, 2016 at 20:26
  • That's a normal thing to appear in your logs, your admin panel attempts to validate that your configuration isn't world readable as a security check. Feb 8, 2016 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.