0

I didn't recently upgrade or change any of my settings in Magento, but as soon as my first order of the day came in today, Magento keeps sending me the same New Order email to my inbox. How do I stop it? I'm receiving hundreds every minute.

I really hope the customer isn't receiving them as well.

  • Probably truncate cron_schedule table to stop the emails. If that doesn't help, disable CRON temporary to investigate the situation. Note disabling cron will also prevent ANY emails going out of Magento like customer registration, newsletter, order, invoice, shipment, etc. – Kalpesh Feb 7 '16 at 21:25
  • Please provide which edition and version of Magento you are using. – Kalpesh Feb 7 '16 at 21:26
  • How do I adjust my cron_schedule? – user12335 Feb 7 '16 at 21:27
  • Magento ver. 1.9.1.1 – user12335 Feb 7 '16 at 21:28
  • just run truncate table cron_schedule; in mysql console or phpmyadmin – Kalpesh Feb 7 '16 at 21:28
0

In phpmyadmin or any mysql software click on you DB which you are using, and then in the upper region you have SQL. Click on that and run command what Kalpesh wrote. truncate table cron_schedule. But this will remove all crons which are in pending state or in progress.

You can disable cron.php on your server to stop running all crons automatically to debug where is the problem.

Another extension which is really good and helpful for crons is AOE/Scheduler. Then you can check timelines, configurations, ....

Hope that helps

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.