0

I am trying to install magento, and i tried everything for what i can do, updating mysql, creating a .bash file in / with file bath to mysql.But all fail. When i run magento-check.php (a script to check if your upto date with all requirment for magento), it tell me your on mysql version 4.x. Whereas phpmyadmin mention something like 5.x version.
I tried installing bitnami magento but it came with magento 2, so not useful for me, as i am trying to run magento 1.9 and greater. Can someone help me out, i am beyond frustrated. It never happened to be before.

  • Please check phpinfo() for safe_mode and if it's On try to change it to Off. – michael Feb 7 '16 at 19:21
  • @michael it is set to off already. – Nofel Feb 7 '16 at 19:24
1

After day of trying to figure out, after looking through the logs and finding the error

"sh: mysql: command not found"

I created a .bash_profile in my ~/ and paste the following in it

export PATH=$PATH:/Applications/MAMP/Library/bin

The above mentioned steps are posted here

.

Saved, and restarted the MAMP, and it fixed. I hope this help everyone who is finding it hard to fix the error, which should be logged by MAMP or Magento docs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.