3

In Magento2, I tried to follow this procedure. Just before the paragraph, "Theme Logo" I wanted to try to apply the theme already. It ended up in an error, then I decided to restart from 0. I deleted the folder <your Magento install dir>/app/design/frontend/<Vendor>/, cleared all caches, but in Stores > Configuration > General > Design > Design Theme dropdown, I still see the name of my theme... It is apparently written somewhere else, question is where and how to clean it?

7

Themes are saved in database after first install.

So you have to delete the theme in your database also.

There is a table in database named as theme.You can use the below code to delete your theme.

Use dbname; delete from theme where theme_id=5;

  • Thanks for that, I had in the meantime the idea to check the database and found that too, you posted before I have time to answer my own question, so you get credit for that :) – Memes Feb 3 '16 at 7:27
8

Just in case if you are removing theme directly(Not in Magento way).

Then follow these steps.

STEP 1 : File Operations

Delete the content from app/design/frontend/<Vendor>.

Delete all the content of folder var/view_preprocessed & pub/static/frontend.

STEP 2 : DB Operations

Go to your theme table and delete the entry for your created theme.

After that...

Go to your core_config_data table and search for theme and you will get path records like design/theme/theme_id replace your default theme id in it.

STEP 3 : Flush cache

Flush your cache php bin/magento cache:flush

Let me know if you still face any problems after that.

0

The first thing you should do is to apply the default Luma or Blank Magento theme to your site to avoid any problems. Clear your cache files, static and all the preprocessed files, and also reindex and deploy static files once you have done that. Make sure the site is operational. Follow the steps above but in Step 1, what is missing is to also delete the app/code/'Vendor' folder for your theme. Also, make sure that you remove all references to your theme from the database. In my case I followed the steps above, but I did not change the theme in my admin and there were some references to my theme left in the core_config_data table so it caused some issues with the site being inaccessible after all this was completed. I've just spent an hour with tech support trying to get it fixed. Thankfully I have a back up from yesterday just in case.

I hope this helps someone else out.

0

additional to answer above : magento module:uninstall Smartwave...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.