2 added 94 characters in body
source | link

I don't have enough reputation to comment, so I'll suggest a few things with an answer.

Make sure the attribute in question is set to "filterable (with results)" or "filterable (no results)" in Use in Layered Navigation.

You might have mistakenly selected this option: Use in Search Results Layered Navigation

If all of your products have the same brand the brand filter won't show if filterable (with results) is selected.

So you might want to change this to filterable (no results) for testing purposes.

I would also recommend disabling 3rd party modules that might have changed the functionality of Layered navigation and check if that helps.

I don't have enough reputation to comment, so I'll suggest a few things with an answer.

Make sure the attribute in question is set to "filterable (with results)" or "filterable (no results)" in Use in Layered Navigation.

If all of your products have the same brand the brand filter won't show if filterable (with results) is selected.

So you might want to change this to filterable (no results) for testing purposes.

I would also recommend disabling 3rd party modules that might have changed the functionality of Layered navigation and check if that helps.

I don't have enough reputation to comment, so I'll suggest a few things with an answer.

Make sure the attribute in question is set to "filterable (with results)" or "filterable (no results)" in Use in Layered Navigation.

You might have mistakenly selected this option: Use in Search Results Layered Navigation

If all of your products have the same brand the brand filter won't show if filterable (with results) is selected.

So you might want to change this to filterable (no results) for testing purposes.

I would also recommend disabling 3rd party modules that might have changed the functionality of Layered navigation and check if that helps.

1
source | link

I don't have enough reputation to comment, so I'll suggest a few things with an answer.

Make sure the attribute in question is set to "filterable (with results)" or "filterable (no results)" in Use in Layered Navigation.

If all of your products have the same brand the brand filter won't show if filterable (with results) is selected.

So you might want to change this to filterable (no results) for testing purposes.

I would also recommend disabling 3rd party modules that might have changed the functionality of Layered navigation and check if that helps.