Take the 2-minute tour ×
Magento Stack Exchange is a question and answer site for users of the Magento e-Commerce platform. It's 100% free, no registration required.

I have to develop module for magento community edition.

Latest version at the moment is 1.9.0.1, released about two weeks ago. There is 1.7.0.0 available for download, but it seems outdated — a 2012 release.

I did not found any data about version fragmentation of existing magento installations.

So, I'm asking here: which versions should I target?

share|improve this question

closed as primarily opinion-based by Marius, davidalger, David Manners, Tim Bezhashvyly Jun 10 at 19:23

Many good questions generate some degree of opinion based on expert experience, but answers to this question will tend to be almost entirely based on opinions, rather than facts, references, or specific expertise.If this question can be reworded to fit the rules in the help center, please edit the question.

    
you should always develop for the latest stable version of Magento –  huzefam Jun 10 at 11:53
1  
yeah, but what about those customers who haven't upgraded yet, or can't upgrade due to some reasons? –  maniac Jun 10 at 12:02
    
Yes this is primarily opinion base, but I think it is a very important question and there are a lot of things which should be thought about before deciding for a set of versions to code against. –  Fabian Blechschmidt Jun 10 at 14:34

2 Answers 2

up vote 1 down vote accepted

Your extensions should support anything newer than 1.7.0.2 (included) as these are versions usually found on live systems. You might not want to worry about older versions (unless you have enough time and resources), but there's very good chance that your software works with versions 1.5 and even 1.4 anyway. It's however almost certain that it DOESN'T work with anything older than 1.4 as there are considerable differences between 1.3 and 1.4.

TL;DR: If your software works with 1.7.0.2 and up, you're good to go.

share|improve this answer
    
The changes between 1.6 and 1.7 are mostly added features, not any core changes, so I would say 1.6. –  Paul Hachmang Jun 10 at 20:21

It depends highly on your customers, as always: Invest as much as needed.

I have customers which run on CE 1.3, 1.4, 1.5, 1.7, 1.8 and we just upgraded a few to 1.9.

There were big breaks between 1.5/1.6 introducing flat tables, change order, etc. to flat and changing mysql4 to resource.

In 1.8.1 form keys were introduced.

So if you have a defined customer set, ask them, which version they run and orient yourself on this. If you don't know I would recommend to target for 1.6, implement TESTs(!!) to easily check, whether your extension runs in all the versions and if needed, backport it later to 1.5 or earlier.

I think beside the problem, that you have a ancient magento version, a lot of shops are customized, so here you will get new problems.

Good luck!

share|improve this answer
1  
Flat sales tables are included in 1.4.2, so anything below 1.5.x is probably a lot of work. –  Paul Hachmang Jun 10 at 20:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.